Complete
The updates are complete!
In progress
System upgrades are in progress
In progress
Maintenance has started
Scheduled
The Longeye App will be temporarily unavailable as we make some upgrades to our system. Apologies for the inconvenience. We will work to complete the upgrades as fast as possible.