Resolved
Uploads are back to functional!
Identified
We believe that we've identified the issue and are working on rolling out a fix.
Investigating
We are aware of an issue affecting investigators' ability to upload new files to cases. The application continues to be available as we work to restore service to uploads as quickly as possible. We apologize for the inconvenience, and will keep you updated as we progress toward a solution.